13/5/2019

zypper : staan er updates klaar (openSUSE)?

Filed under: — cybrarian @ 11:15 am

Op een desktop krijg je een aanduiding in de takenbalk dat er updates zijn: groen voor gewone, rood voor security updates. Maar hoe zie je dat op een server?

zypper list-updates
Je krijgt dan:

Retrieving repository ‘openSUSE-Leap-42.3-Update’ metadata ———[done]
Building repository ‘openSUSE-Leap-42.3-Update’ cache ——[done]
Loading repository data …
Reading installed packages …

en daarna een tabel met de huidige versies en de beschikbare versies van alle packages:
(met nog extra: aktief = “v”, repository, naam en de architectuur (bv x86_64):

S | Repository | Name | Current Version | Available Version | Arch

Met een rode kleur wordt het deel van het versienummer aangegeven dat verschilt, zodat je snel op het zicht kan zien wat er anders is (enkel bij bovenste lijn zichtbaar hieronder).

Loading repository data...
Reading installed packages...
S | Repository                | Name                            | Current Version             | Available Version           | Arch  
--+---------------------------+---------------------------------+-----------------------------+-----------------------------+-------
v | openSUSE-Leap-42.3-Update | SUSEConnect                     | 0.3.12-2.13.1               | 0.3.17-2.17.1               | x86_64
v | openSUSE-Leap-42.3-Update | glibc                           | 2.22-22.1                   | 2.22-25.1                   | x86_64
v | openSUSE-Leap-42.3-Update | glibc-32bit                     | 2.22-22.2                   | 2.22-25.2                   | x86_64
v | openSUSE-Leap-42.3-Update | glibc-extra                     | 2.22-22.1                   | 2.22-25.1                   | x86_64
v | openSUSE-Leap-42.3-Update | glibc-locale                    | 2.22-22.1                   | 2.22-25.1                   | x86_64
v | openSUSE-Leap-42.3-Update | kpartx                          | 0.7.1+101+suse.1d10b44f-9.1 | 0.7.1+108+suse.29efb7b-12.1 | x86_64
v | openSUSE-Leap-42.3-Update | libidn11                        | 1.28-9.3.1                  | 1.28-9.6.1                  | x86_64
v | openSUSE-Leap-42.3-Update | libjavascriptcoregtk-4_0-18     | 2.24.0-24.1                 | 2.24.1-27.1                 | x86_64
v | openSUSE-Leap-42.3-Update | libopenssl1_0_0                 | 1.0.2j-35.1                 | 1.0.2j-38.1                 | x86_64
v | openSUSE-Leap-42.3-Update | libopenssl1_0_0-32bit           | 1.0.2j-35.1                 | 1.0.2j-38.1                 | x86_64
v | openSUSE-Leap-42.3-Update | libwebkit2gtk-4_0-37            | 2.24.0-24.1                 | 2.24.1-27.1                 | x86_64
v | openSUSE-Leap-42.3-Update | libwebkit2gtk3-lang             | 2.24.0-24.1                 | 2.24.1-27.1                 | noarch
v | openSUSE-Leap-42.3-Update | nscd                            | 2.22-22.1                   | 2.22-25.1                   | x86_64
v | openSUSE-Leap-42.3-Update | openssl                         | 1.0.2j-35.1                 | 1.0.2j-38.1                 | x86_64
v | openSUSE-Leap-42.3-Update | perl-IO-Socket-SSL              | 1.962-7.3                   | 2.052-8.3.1                 | noarch
v | openSUSE-Leap-42.3-Update | webkit2gtk-4_0-injected-bundles | 2.24.0-24.1                 | 2.24.1-27.1                 | x86_64

Powered by WordPress