25/10/2022

Mysql/Mariadb, phpMyAdmin: Illegal mix of collations

Filed under: — cybrarian @ 12:38 pm

De LAMP server draait MariaDb, gebruiker heeft toegang met phpMyAdmin vanop dezelfde machine.

Bij het opvragen van de “privileges” in phpMyAdmin (url: hieronder)…
http://localhost/phpMyAdmin/server_privileges.php?db=mysql&table=user&checkprivsdb=mysql&checkprivstable=user&viewing_mode=table

…krijg ik volgende foutmelding:

#1267 – Illegal mix of collations (utf8mb4_general_ci,COERCIBLE) and (utf8mb4_unicode_ci,COERCIBLE) for operation ‘<>‘
Current selection does not contain a unique column. Grid edit, Edit, Copy and Delete features may result in undesired behavior. Documentation

Ik ga deze oplossing uitproberen als ik tijd heb:
(stackoverflow)

20/10/2022

Top tien

Filed under: — cybrarian @ 11:44 am

Top is het bekende commandolijn programma om de draaiende programma’s op de computer te onderzoeken: processorcapaciteit en geheugen en andere details zijn per gestart proces zichtbaar en worden lopend aangepast.
Daardoor verspringt de hele tabel met de frequentie van het updaten van de gegevens, omdat ze bv in volgorde van cpu-gebruik gesorteerd weergegeven worden.

Wil je een bepaald proces of een groep bij elkaar horende processen beter kunnen volgen kan je de opties oproepen door in het top scherm op de letter “o” te drukken. Je krijgt een lijn die begint met “Add filter ..”

Dan tik je bv:
COMMAND=kopano

Daarna worden alle processen getoond met “kopano” in hun naam (waarmee ze opgestart zijn).

    PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND                                                                                                     
   1317 kopano    20   0   13.9g   2.2g  21880 S  59.1   9.5   1131:24 kopano-server                                                                                               
   2382 kopano    20   0  732844 490232  13556 S  15.9   2.0 264:24.45 kopano-search                                                                                               
  77090 kopano    20   0 2218628 965744  22616 S   5.6   3.9  13:19.92 kopano-gateway                                                                                              
    845 kopano    20   0 1091352 169412  22420 S   0.0   0.7   5:34.42 kopano-dagent                                                                                               
    857 kopano    20   0   80660  15868  13764 S   0.0   0.1   0:00.63 kopano-ical                                                                                                 
    863 kopano    20   0  291404  19644  16720 S   0.0   0.1   0:03.35 kopano-monitor                                                                                              
    866 kopano    20   0  492056  53556  20292 S   0.0   0.2   0:08.95 kopano-spooler                                                                                              
    867 kopano    20   0   89448  16412  14276 S   0.0   0.1   0:00.05 kopano-statsd                                                                                               
   2366 kopano    20   0  303540  62120  26628 S   0.0   0.3  11:42.27 kopano-search                                                                                               
  95966 kopano    20   0  281544  22084   8096 S   0.0   0.1   0:00.07 kopano-search  

18/10/2022

Element desktop client voor Matrix chat server

Filed under: — cybrarian @ 10:09 am

De non-profit https://matrix.org/ foundation publiceert de Matrix open standard voor een gedecentraliseerde online communicatie. De software is open source en je kan je eigen (“home”) server draaien. Er zijn “bridges” om te overbruggen naar andere platformen.

Er zijn clients voor verschillende platformen, zowel mobiel als desktop.

Voor opensuse bv: element-desktop.
(Geen officieel pakket, wel een versie 1.11.10 community en experimenteel voor 15.3, 15.4)
Er is een officiële 1.11.8 release voor tumbleweed.

7/10/2022

OpenSUSE 15.4 Plymouth foutmelding

Filed under: — cybrarian @ 1:57 pm

Ik heb twee soorten foutmeldingen ivm Plymouth:

  • in update app (software updates)
  • bij het opstarten (bootscherm)

Foutmelding in update app
Bij een update van de desktop-softwaremeldingen krijg ik “Update Error”:

the installed plymouth-lang-0.9.5~git20210406.e554475-150400.3.5.1.noarch requires ‘plymouth = 0.9.5~git20210406.e554475’, but this requirement cannot be provided

Er blijft 1 update staan:
openSUSE-SLE-15.3-2022-3024(1)

Ook met zypper geraak ik er niet voorbij.

Ik krijg warnings als:

zypper up
Retrieving repository ‘SUSE:SLE-15-SP3:GA’ metadata ………………………………………………………….[error]
Repository ‘SUSE:SLE-15-SP3:GA’ is invalid.
[https-download.opensuse.org-27ea0f2b|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP3:/GA/pool/] Valid metadata not found at specified URL
History:
– [https-download.opensuse.org-27ea0f2b|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP3:/GA/pool/] Repository type can’t be determined.

Please check if the URIs defined for this repository are pointing to a valid repository.
Warning: Skipping repository ‘SUSE:SLE-15-SP3:GA’ because of the above error.

En ..

Warning: Repository ‘openSUSE:Backports:SLE-15-SP4’ appears to be outdated. Consider using a different mirror or server.
Reading installed packages…

Bovendien wil één update niet installeren (zie boven):

The following 9 package updates will NOT be installed:
dos2unix kpartx libmpath0 logrotate multipath-tools plymouth plymouth-dracut plymouth-scripts power-profiles-daemon

(En ik krijg foutmeldingen op plymouth bij het opstarten op één toestel)

De officiële URL zou zijn:

https://download.opensuse.org/update/leap/$releasever/backports/

Ik weet niet of al die andere die problemen geven er uit mogen; daarbij zie ik bij het opstarten wel een plymouth foutmelding…hoe geraakt die dan opgelost?

Ik zet voorlopig alle repo’s met foutmeldingen af…

En ook alle andere die er onnodig uitzien:

URL: https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/GA/pool/
URL: https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/Update/pool/
URL: https://download.opensuse.org/repositories/SUSE:/SLE-15-SP2:/GA/pool/
URL: https://download.opensuse.org/repositories/SUSE:/SLE-15-SP2:/Update/pool/
URL: https://download.opensuse.org/repositories/SUSE:/SLE-15-SP3:/GA/pool/
URL: http://download.opensuse.org/update/leap/15.3/sle/
URL: https://download.opensuse.org/repositories/SUSE:/SLE-15-SP4:/GA/pool/

De meeste daarvan zijn meegekomen toen ik Gambas3 installeerde (Gambas 3.17 terwijl op andere distro’s de versie rond 1.34 zit).

Daarna verandert de melding in “Update error” “Couldn’t find package”.

Door de meldingen in zypper

Loading repository data…
Warning: Repository ‘openSUSE:Backports:SLE-15-SP4:Checks’ appears to be outdated. Consider using a different mirror or server.

zette ik volgende nog af:

URL: https://download.opensuse.org/repositories/SUSE:/SLE-15:/Update/pool/
URL: https://download.opensuse.org/repositories/openSUSE:/Backports:/SLE-15-SP4/standard/
URL: https://download.opensuse.org/repositories/openSUSE:/Backports:/SLE-15-SP4:/Checks/standard/

Darana heeft ook zypper geen commentaar meer:

zypper up
Loading repository data…
Reading installed packages…
Nothing to do.

Plymouth foutmelding bij opstarten (bootscherm)

Op één van mijn opensuse 15.4 toestellen heb ik blijkbaar iets anders gedaan, want daar krijg ik bij het opstarten een foutmelding op plymouth. Plymouth heeft blijkbaar iets te maken met het tonen van een grafisch beeld in plaats van lettertjes bij het starten:
https://software.opensuse.org/package/plymouth

Misschien moet ik op dit toestel plymouth maar afzetten om de foutmelding kwijt te geraken, ik hoef de animatie niet terug en ben best tevreden met de gedetailleerde boot messages.

Volgens https://linuxconfig.org/how-to-disable-plymouth-on-linux:

In de instellingen in /etc/default/grub moeten een paar parameters anders ingesteld worden (of verwijderd worden blijkbaar):
splash=silent
quiet

Die vind ik in de lijn:

GRUB_CMDLINE_LINUX_DEFAULT="splash=silent preempt=full mitigations=auto quiet security=apparmor"

Dan moet de bootloader terug gegenereerd worden met:

$ sudo update-bootloader

Of als root bv:
mcedit grub
(verwijder)
update-bootloader
Deze laatste geeft geen uitleg als hij klaar is.

Nadien krijg ik bij het opstarten alle startmeldingen over het scherm rollen, zo snel dat je ze amper kan lezen, en er staat ook nog altijd één rode Plymouth melding tussen. Het zijn ook massa’s meer meldingen dan in de begindagen (dus ik snap wel dat ze het vervangen door een grafisch wacht-scherm).
Bovendien heb ik twee monitors op hun zijkant gekanteld, 2 A4 portrait zeg maar, zodat de boot messages op de twee schermen van het midden naar buiten lopen (op zijn kant). Misschien moet ik toch ook maar eens uitzoeken hoe ik het terug in oorspronkelijke toestand krijg.

Ik kan al eens proberen met om de beurt:
– quiet er terug in te zetten. (ok: ik zie nog wel de foutmeldingen Failed to strat Plymouth, dan is er even niets, en dan de bekende suse lamp – dit is wel bij een reboot, ik moet niet inloggen nu). Mij prima, ik houd deze.
– splash=silent er terug in te zetten. (voorlopig niet geprobeerd)

Yast2
En misschien kan je ook via yast2 …?
Software, zoek op “plymouth”.
Ik zie dat er een alternatieve versie beschikbaar is.
Huidige is van: SUSE Linux Enterprise 15.
Ik schakel om naar de Alternate “Main repo” versie.

Powered by WordPress