12/4/2021

Git: in verkeerde branche gewerkt

Filed under: — cybrarian @ 4:03 pm

Ik zit ijverig te werken en nadien zie ik dat ik in de master branch bezig ben ipv de dev branch.
Ik heb nog geen git add of commit gedaan.
Ik kan natuurlijk alles weggooien en de master terugzetten op een vorig punt.

Maar ik wil de wijzigingen wel bijhouden, en ik wil die in de dev krijgen.

De aanbevelingen die ik lees gaan ongeveer zo:
– maak een nieuwe branch vanuit die master die je gewijzigd hebt (maar nog niet ge-commit), geef hem een tijdelijk naam bv tempdev.
git checkout -b tempdev
– voeg daar alle bestanden toe en commit al je werk
git add .
git commit -m "some new work"

– check of je de dev branch hebt:
git branch -l
master
* tempdev

Als je de dev branch niet hebt, kijken of hij er remote wel is:
git branch -lr (opgelet dit kan een vertekend beeld geven als die recent is bijgemaakt en je niet hebt bijgewerkt…)

origin/HEAD -> origin/master
origin/master

Dus eerst synchroniseren met online:
git fetch

remote: Enumerating objects: 32, done.
remote: Counting objects: 100% (28/28), done.
remote: Compressing objects: 100% (16/16), done.
remote: Total 16 (delta 12), reused 0 (delta 0)
Unpacking objects: 100% (16/16), done.
From git://git.code.sf.net/p/myproject/code
* [new branch] dev -> origin/dev
0c4e870..b8c15dc master -> origin/master

git branch -rl
origin/HEAD -> origin/master
origin/dev
origin/master

Beter!
– schakel naar dev branch en merge die met devtemp (importeert de devtemp wijzigingen).
git checkout dev
git merge tempdev

– commit en push zodat de (online) “remote” dev branch is bijgewerkt.
– schakel naar die je master en reset hem naar de laatste versie (van remote halen dus).

(wordt vervolgd nadat ik het ook effectief uitgeprobeerd heb)

Fout tijdens bijwerken (OpenSUSE/KDE)

Filed under: — cybrarian @ 9:02 am

Vastgesteld op openSUSE 15.2 en 15.3 Beta.
Na een paar dagen niet-gebruik staat mijn desktop vol met meldingen:

Fout tijdens bijwerken.
Failed to obtain authentication.

De foutmelding komt van het automatische checken van de updates. Ze hebben er niet aan gedacht dat de meldingen niet weggeklikt worden als de desktop onbeheerd is achtergelaten. En dus komt het scherm na een week vol te staan met een mozaïek van foutmeldingen (11 hoog, 6 breed), die je dan één voor één moet wegklikken, het lijkt wel een game. En dan nog een reeks onderaan rechts die als stapel wachten om afgeklikt te worden; nl meer dan 148. Ik kan me voorstellen dat het de desktop op den duur doet hangen of crashen.

Opmerking:
– Op een ander systeem met openSUSE, dat wel ingelogd stond, maar waar de desktop niet het aktieve scherm was (na bv CTRL-ALT-F1), deed het euvel zich niet voor. Pas op het moment dat die desktop terug aktief wordt (ALT-F7), gaat de updater de updates checken.
– Als je zelf een applicatie als screensaver hebt ingesteld, kan het nog gekker worden; de desktop wordt als aktief beschouwd voor de melding van de updates, en die lijken dan weer als aktiviteit beschouwd te worden voor de screensaver, die dus nadien een tweede keer je alternatieve screensaver start (terwijl die niet door jou was afgesloten).

7/4/2021

Brother multifunctional in openSUSE tumbleweed

Filed under: — cybrarian @ 10:34 pm

Op zoek naar een Brother MFC laser-kleur printerdriver; kijk eerst in softwarebeheer Yast, Software, zoek, brother…

printer-driver-brlaser – Driver for (some) Brother laster printers

In de uitleg erbij staat dat de meeste Brother printers een standaard printtaal als PCL of Postscript ondersteunen. Als je een monochrome Brother laserprinter hebt, of een multifunctionele, en andere open source drivers niet werken, kan je deze proberen.

Er worden een aantal ondersteunde printers opgesomd:

Brother DCP-1510 series Brother DCP-1600 series Brother DCP-7030 Brother DCP-7040 Brother DCP-7055 Brother DCP-7055W Brother DCP-7060D Brother DCP-7065DN Brother DCP-7080 Brother DCP-L2500D series Brother DCP-L2520D series Brother DCP-L2540DW series Brother HL-1110 series Brother HL-1200 series Brother HL-2030 series Brother HL-2140 series Brother HL-2220 series Brother HL-2270DW series Brother HL-2375DW Brother HL-2390DW Brother HL-5030 series Brother HL-L2300D series Brother HL-L2320D series Brother HL-L2340D series Brother HL-L2360D series Brother MFC-1910W Brother MFC-7240 Brother MFC-7360N Brother MFC-7365DN Brother MFC-7420 Brother MFC-7460DN Brother MFC-7840W Brother MFC-L2710DW series Lenovo M7605D

Ook vind je een scannerdriver:

brscan4 – Brother Scanner Driver
SANE drivers from Brother for brscan4 compatible models.

Daarna de printer installeren via Yast.
(zie ook http://linuxuser.copyleft.be/liglog/?p=6739)

Als je nummer er niet tussen staat, bv MFC9465, kan je een andere proberen, bv en uitproberen wat werkt.
– 7420 (brlaser v6)… testprint 2 pagina’s: apart, rare vakjes en vlakjes op begin van blad, rest leeg
– MFC 9500 … testprint 2 pagina’s, apart geprint, zwart-wit als gewone laserprinter, niet recto-verso.
– 6550 MC …testprint 2 pagina’s: apart geprint, zwart-wit als gewone laserprinter, niet recto-verso.
– …

Beter toch de brother drivers afhalen…

https://support.brother.com/g/b/downloadend.aspx?c=be&lang=nl&prod=mfc9465cdn_eu_as&os=127&dlid=dlf006893_000&flang=4&type3=625

Driver Install Tool
The tool will install LPR, CUPSwrapper driver and scanner driver (for scanner models).
22/01/2021
(2.2.2-2) 0.02
MB

Terminal, gunzip linux-brprinter-installer-*.*.*-*.gz
Dan moet je het programma uitvoerbaar maken en als root draaien.

localhost:/home/cybrarian/Downloads # chmod +x linux-brprinter-installer-2.2.2-2
localhost:/home/cybrarian/Downloads # ./linux-brprinter-installer-2.2.2-2
Input model name ->MFC-9465CDN
You are going to install following packages.
mfc9465cdnlpr-1.1.1-5.i386.rpm
mfc9465cdncupswrapper-1.1.1-5.i386.rpm
brscan4-0.4.10-1.x86_64.rpm
brscan-skey-0.3.1-2.x86_64.rpm
OK? [y/N] ->y

Licenties bevestigen y, y..

Powered by WordPress