3/10/2021

KMail start niet

Filed under: — cybrarian @ 1:29 pm

KMail start niet meer als ik op het icoon klik
KMail vanop desktop of uit menu starten gaat niet (sluit onmiddellijk terug af).
kmail: symbol lookup error: /usr/lib64/libQt5WebEngineCore.so.5: undefined symbol: hb_subset_input_set_drop_hints

Eerst kan je proberen KMail uit het menu te starten; voor de klassieke menu-indeling: Menu, Internet, KMail (Mail Client).
– Even terugkijkend naar vorige KMail problemen: je kan ook starten van de commandolijn; open een terminal en tik “kmail”. Het e-mail programma opent dan vanuit deze terminal (dus je moet die terminal open laten staan, anders is kmail mee afgesloten).
In dit geval krijg ik de volgende foutmelding:
gebruiker@localhost:~> kmail
kmail: symbol lookup error: /usr/lib64/libQt5WebEngineCore.so.5: undefined symbol: hb_subset_input_set_drop_hints

Mogelijk ontstaan door onvolledig uitgevoerde update?

Pakket
In Yast ga ik het pakket zoeken en ik “update” het.
(Yast, zoek, tik hele pakketnaam of deel; vink “bestandenlijst” aan)
Bij zoek op “libQt5WebEngineCore” krijg ik zo 1 resultaat.
De vermelde link is een van de bestanden van dit pakket:

libQt5WebKit5 - Qt5 WebKit Library

Ik probeer het te updaten.
Dat blijkt niet te helpen.

Herinstalleren?
Ik ga het de-installeren en opnieuw installeren. Daarbij krijg je de vraag van een heel aantal andere paketten die er afhankelijk zijn of je die ook wil de-installeren. Nee, behouden met afgebroken functionaliteit.
Dan terug installeren.

libQt5WebKit5 - Qt5 WebKit Library

Bijgewerkte pakketten: 1
libqt5-qtwebengine

installatielogboek:

libqt5-qtwebengine wordt gedownload (downloadgrootte 45,63 MiB)
libqt5-qtwebengine-5.15.3-lp152.3.3.4.x86_64.rpm wordt geïnstalleerd (geïnstalleerde grootte 149,91 MiB

Ook dat helpt niet.


Andere/Oudere versie?

Ik kies van WebKit een oudere versie uit een andere repo:
(helaas niet genoteerd)
Daarna werkt KMail terug (maar het probleem zal dan waarschijnlijk terugkomen).

Ik update terug naar de nieuwere versie: probleem is terug, kmail werkt niet. Bovendien krijg ik die oudere versie niet meer aangeboden.

Chromium?
Omdat het te maken heeft met web, misschien met het renderen van webpagina’s of opmaak in mail volgens html, probeer ik eens een andere “engine”. Misschien dat bepaalde onderdelen zo mee geüpdate worden; of een andere versie krijgen enz.
Chromium geïnstalleerd. Lost het probleem van undefined symbol: hb_subset_input_set_drop_hints niet op.

Okonadi?
– Ook uit vorige problemen probeer ik of het aan akonadi ligt (de server die in de achtergrond draait voor de plaatselijke mail).
Open een terminal en vraag de status op, sluit akonadi af, wacht even, en start akonadi terug op.

akonadictl status
akonadictl stop
sleep 5
akonadictl start

Tussendoor maar vooral op het einde kan je kijken of het effect heeft op kmail; bij mij startte kmail nadien terug vanaf het icoon op de desktop.

Soms lijkt het iets te maken te hebben met updates; uitloggen en terug inloggen kan je ook proberen om alles terug netjes te laten starten op je desktop, zeker na een update. Sommige updates geven trouwens expiciet aan dat je je systeem moet herstarten.

Oplossing: harfbuzz

Opgelost maar niet begrepen
Ik ga op zoek naar het andere deel van de foutmelding: undefined symbol: hb_subset_input_set_drop_hints.

Ik vind ergens een discussie van programmeurs over lettertypes.
https://github.com/harfbuzz/harfbuzzjs/issues/9

Ik ga op zoek in Yast naar paketten die daarmee te maken hebben bv “harfbuzz”, ik ik vind een eigenaardigheid: een pakket dat een andere, nieuwere versie heeft dan de paketten waar het bij hoort. Ik upgrade het naar de normale versie (downgrade dus eigenlijk) .. en KMail start terug!

Andere vermeldingen:
https://lists.opensuse.org/archives/list/factory@lists.opensuse.org/thread/ZBYJWONSO7UHD7WW2I2C6ODPKLTCDOIC/

Reacties zijn gesloten.

Powered by WordPress